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ABSTRAK

The development of information and communication technology has brought significant
impacts in various sectors, including education, with the implementation of a more efficient
attendance system. This research aims to develop a QR Code-based attendance system
integrated with Internet of Things (IoT) technology at SMK Tl ZAMIGA, considering that
the manual attendance process that is still used today results in recording errors of around
20%. The designed system utilizes devices such as Arduino Mega, QR Code Scanner,
Ultrasonic Sensor, and NodeMCU to record student attendance automatically and in real-
time. In addition, this system allows teachers to input student practicum grades, with easy
data access through a website built using PHP and XAMPP technology. With the
development of this attendance system, it is expected to improve efficiency, security, and
student discipline in the learning process.

Kata Kunci: attendance; gr code; iot; arduino mega; practicum score.

PENDAHULUAN

Perkembangan teknologi informasi dan komunikasi telah memengaruhi berbagai bidang
kehidupan, termasuk pendidikan. Salah satu dampak signifikan yang dihasilkan adalah
penggunaan komputer dalam mengolah data, yang sangat memudahkan berbagai aktivitas
administratif di lingkungan pendidikan. Teknologi ini memungkinkan proses yang lebih
efisien dan efektif, serta memberikan kemudahan dalam mengakses dan menyimpan
informasi penting, seperti absensi siswa. Absensi adalah salah satu aspek krusial dalam dunia
pendidikan karena terkait langsung dengan kedisiplinan dan kinerja akademik siswa.
Pencatatan kehadiran yang akurat menjadi salah satu indikator penting dalam menilai
kedisiplinan dan partisipasi siswa dalam kegiatan belajar mengajar.

Namun, meskipun teknologi telah berkembang pesat, banyak sekolah yang masih
mengandalkan sistem absensi manual. Sistem manual ini, meskipun sederhana, memiliki
berbagai kelemahan, seperti rentan terhadap kesalahan pencatatan, kecurangan, dan hilangnya
data. Kesalahan ini dapat berdampak pada keakuratan catatan kehadiran, yang pada
gilirannya dapat memengaruhi evaluasi dan penilaian terhadap siswa. Proses manual yang
memerlukan waktu lebih lama juga menyulitkan guru dan pihak sekolah dalam melakukan
pemantauan terhadap kehadiran siswa secara efektif. Dengan adanya masalah tersebut,
pengembangan sistem absensi yang lebih modern dan efektif menjadi sangat penting untuk
menjawab tantangan ini.
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Seiring dengan perkembangan teknologi, sistem absensi berbasis QR Code dan Internet
of Things (1oT) mulai diperkenalkan sebagai solusi untuk menggantikan metode manual. QR
Code adalah teknologi yang memungkinkan proses identifikasi secara cepat dan akurat hanya
dengan memindai kode yang ada. Sementara itu, 10T memberikan kemampuan untuk
menghubungkan berbagai perangkat, sehingga memungkinkan pemantauan dan pengolahan
data secara otomatis dan real-time. Penggunaan kedua teknologi ini dalam sistem absensi
dapat mempermudah pencatatan kehadiran siswa dengan lebih efisien, mengurangi risiko
kesalahan, dan memungkinkan pemantauan yang lebih akurat. Penelitian sebelumnya yang
dilakukan oleh Zainal Akbar (2022) mengungkapkan bahwa penggunaan QR Code dalam
pencatatan absensi di laboratorium dapat mempercepat proses dan mengurangi kesalahan.
Namun, teknologi loT belum diintegrasikan dalam sistem tersebut, sehingga pengawasan
absensi masih terbatas pada pencatatan manual setelahnya.

Di SMK Tl ZAMIGA, sistem absensi di laboratorium masih dilakukan secara manual,
yang berakibat pada ketidakakuratan pencatatan. Sekitar 20% data absensi siswa tidak
tercatat dengan tepat, yang tentunya menjadi masalah dalam administrasi dan evaluasi
pembelajaran. Oleh karena itu, perlu adanya pengembangan sistem absensi yang lebih
canggih dan efisien, dengan memanfaatkan teknologi terbaru. Penelitian ini bertujuan untuk
merancang dan mengembangkan sistem absensi berbasis QR Code yang terintegrasi dengan
teknologi 10T di laboratorium SMK Tl ZAMIGA. Dengan menggunakan sistem ini,
kehadiran siswa dapat dicatat secara otomatis dan akurat, serta dapat dipantau secara real-
time oleh guru dan pihak sekolah.

Untuk pengembangan sistem tersebut, beberapa perangkat teknologi digunakan, seperti
Arduino Mega, QR Code Scanner, Sensor Ultrasonik, Push Button, RTC Module, Buzzer,
LED, LCD, dan NodeMCU. Arduino Mega sebagai mikrocontroller utama berfungsi untuk
mengontrol seluruh perangkat yang terhubung dalam sistem. QR Code Scanner digunakan
untuk memindai kode QR yang mencatat kehadiran siswa, sementara sensor ultrasonik dan
RTC Module digunakan untuk mendeteksi jarak dan mencatat waktu kehadiran secara real-
time. Push button digunakan sebagai alat input tambahan untuk kebutuhan tertentu, seperti
konfirmasi kehadiran. Selain itu, sistem ini dilengkapi dengan Buzzer dan LED yang
memberi sinyal visual dan suara ketika siswa berhasil melakukan absensi. Data absensi yang
tercatat kemudian disimpan dan dapat diakses melalui website yang dibangun menggunakan
PHP, HTML, PhpMyAdmin, dan XAMPP.

Sistem ini tidak hanya mengoptimalkan pencatatan absensi, tetapi juga menyediakan
kemudahan bagi guru untuk menginput nilai praktikum siswa. Nilai ini dapat diakses
langsung melalui website yang telah disediakan, sehingga memberikan transparansi dalam
evaluasi. Dengan kemudahan akses dan pengolahan data, sistem ini diharapkan dapat
meningkatkan efisiensi administrasi di laboratorium dan membantu guru dalam memantau
perkembangan akademik siswa secara lebih baik. Selain itu, penggunaan sistem absensi
otomatis berbasis QR Code dan IoT juga dapat mengurangi kemungkinan terjadinya
kecurangan atau penyalahgunaan dalam pencatatan kehadiran, karena sistem ini bekerja
secara transparan dan tidak dapat diubah oleh pihak yang tidak berwenang.

Keberhasilan pengembangan sistem absensi berbasis QR Code dan I0T ini diharapkan
dapat memberikan solusi yang lebih aman, otomatis, dan real-time dalam pencatatan
kehadiran siswa. Selain itu, sistem ini juga mendukung peningkatan kualitas pembelajaran
dan kedisiplinan siswa di SMK TI ZAMIGA. Dengan sistem yang lebih modern dan efisien,
diharapkan dapat tercipta lingkungan belajar yang lebih terorganisir, di mana data absensi
yang akurat dan tepat waktu dapat memberikan dampak positif terhadap proses evaluasi dan
pengembangan siswa. Dengan demikian, pemanfaatan teknologi dalam pendidikan,
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khususnya dalam pencatatan absensi, dapat memberikan kontribusi besar dalam peningkatan
kualitas pendidikan di masa depan.

METODE PENELITIAN

Kerangka kerja penelitian merupakan tahap awal yang dilakukan untuk pembuatan
sistem. Dengan adanya kerangka kerja penelitian ini, maka susunan dari pembuatan sistem
menjadi lebih jelas. Dalam perancangan ini banyak yang harus ditinjau terlebih dahulu.
Untuk mempermudah dan memperjelas langkah- langkah yang akan digunakan untuk
menyelesaikan masalah tersebut, maka diperlukanlah suatu kerangka kerja penelitian yang
digunakan. Adapun kerangka kerja penelitian yang digunakan dapat dilihat pada gambar
berikut.

[ Hasil dan Pembahasan I

|
A

I Implementasi Ststem I

Gambar 1 Kerangka Kerja Penelitian
1. Analisis Sistem

Tahap analisis adalah tahap yang sangat penting dalam pengembangan sistem
karena pada tahap ini dilakukan evaluasi menyeluruh terhadap sistem yang ada. Proses ini
bertujuan untuk menemukan solusi yang paling tepat dalam memecahkan masalah yang telah
diidentifikasi sebelumnya. Dalam penelitian ini, analisis sistem dimulai dengan identifikasi
masalah yang dihadapi oleh pengguna sistem absensi di laboratorium SMK TI ZAMIGA.
Setelah masalah teridentifikasi, peneliti akan melakukan analisis data yang lebih mendalam
untuk menggali penyebab utama masalah tersebut.

Data yang dikumpulkan melalui observasi, wawancara dengan guru dan siswa,
serta studi literatur akan dianalisis menggunakan teknik analisis yang sesuai, seperti analisis
deskriptif atau kuantitatif. Analisis ini akan memberikan gambaran yang jelas tentang
kelemahan sistem absensi yang ada, seperti ketidaktepatan waktu pencatatan, kesalahan
manual, atau ketergantungan pada metode absensi tradisional yang kurang efisien.

Setelah menganalisis data, peneliti akan merumuskan solusi baru yang berbasis
teknologi, yaitu sistem absensi berbasis QR Code dengan loT, yang diharapkan dapat
mengatasi masalah yang ada. Tahap ini juga mencakup pembuatan dokumen desain awal,
seperti context diagram, data flow diagram, blok diagram, dan flowchart, yang
menggambarkan bagaimana sistem baru ini akan bekerja, bagaimana aliran data akan terjadi,
serta bagaimana interaksi pengguna dengan sistem akan berlangsung. Semua hasil analisis ini
akan digunakan untuk merancang alat dan sistem yang lebih efektif dan efisien.
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2. Perencanaan Sistem
Dalam memudahkan desain dan perencangan sistem, digunakan Block Diagram,
Context Diagram, Data Flow Diagram, Flowchart dan Desain Sistem, agar sistem yang dibuat
jelas dan sesuai dengan rancangan.
1. Context Diagram
Context diagram merupakan tingkat tertinggi dalam diagram aliran data yang hanya
memuat satu proses sehinga menunjukan sistem secara keseluruhan.

Arduino Mega
2560 R3
A
DATA INTRUKSI
Smyal Sinyal
PushButton 1 [——rr>|  RANCANGBANGUN [“pii LED1
r Sinyal SISTEMABSENSIDAN | ¢,
NILAI PRATIKUM
; | Sinyal Sinyal
cor Ultrasonik § ST y
Sensor Ultrasonik |51 > MENGGUNAKAN QR |———— Buzzer
Sinval CODE BERBASISIOT | .
QR. Code Scanner W Dm",; LCD
= DI LABORATURIUM 2
. Sinyal
Sinyal
RIC = SMEK TI ZAMIGA NodeMCU
Digital 40—
g1

. =

DATA INTRUKSI

A 4

Modul Program

Gambar 2 Context Diagram

2. Data Flow Diagram
Data flow diagram (DFD) adalah suatu diagram yang menggunakan notasi untuk arus
dari sistem agar memahami sistem secara logika, terstruktur dan jelas.

857 E-ISSN 2961-7553

This work is licensed under a Creative Commons Attribution 4.0 International License. P-1SSN 2963-8135




TOFEDU: The Future of Education Journal Vol 4, No.4, 2025

Modad Program
A
INSTRUKS] DATA
g : 7 10 N\
. X1 St x4 weoul| oengierm Instrukm |
| Push Bunon | feep uj':'na—u ke nfull L e akuvasi indlowor > LED|
L " ; masuk
\—,.’
f ¢ e
X 2y
| Mespoim Inswukon | sl | Mengurees boserodest |
| Push Bution 2 > -] 4 k
:P\n. Butioe 2 — aktivasi mode kebass | akthas mdikator —» LED21
= kelusr
- — —
/ =3 \ e
Senace wadt | Mennim Instruks | o + ™ | Menpinm: Iestrol i
o | -~ w3 Meapinm Instraies | s T
(remaonik meagukour jarak ——» Arduino Mega 250 R3  — Seci sioval il » Buorrer
\
-~ % -
QR Code o Mengism lotruks " — | Menginim Instruksi =
— 3 — N D
Scamner memmdes QR Code " | menaspulican status s
) L J
e - O B T
> Mengirze bratyulng | % | Mengmm lastraicsi - | Mesenma data dan 3
RIC o s — - = i NodeMCU [— b
walkts dan tanggal { data ke server dadC l serves |>’ Webrite

Gambar 3 Data Flow Diagram
3. Blok Diagram
Blok diagram merupakan sebuah diagram yang dibuat untuk memetakan proses kerja dari
suau sistem. Hal ini bertujuan untuk memudahkan peneliti dalam mengenal komponen-
komponen yang akan dipakai dalam membangun sebuah sistem.

LED1
Push Button 1
LED2
Push Button 2 —>
> Buzzer
Sensor Ultrasonik N Arduino Mega 2560 R3
LCD
QR Code Scanner —>
& NodeMCU
<_
RIC —>
WEBSITE
Gambar 4 Blok Diagram

4. Flowchart
Flowchart atau bagan alur adalah diagram yang menampilkan langkah-langkah dan
keputusan untuk melakukan sebuah proses dari suatu program. Setiap langkah
digambarkan dalam bentuk diagram dan dihubungkan dengan garis atau arah panah.
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Flowchart berperan penting dalam memutuskan sebuah langkah-langkah atau
fungsionalitas dari sebuah proyek dalam pembuatan program.
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3. Sistem Minimum Arduino Mega 2560 R3

Rangkaian sistem minimum berfungsi untuk menjalankan Arduino Mega agar dapat
bekerja sesuai dengan yang dibutuhkan dimanan perancangannya bertujuan untuk
mempermudah penggunaan alat. Modul program Arduino Mega dapat dilihat pada gambar
dibawah ini.

® 859
@ - E-ISSN 2961-7553
P-1SSN 2963-8135

This work is licensed under a Creative Commons Attribution 4.0 International License.




TOFEDU: The Future of Education Journal Vol 4, No.4, 2025

o0

Gambar 6 Rangkaian Arduino Mega 2560 R3

HASIL DAN PEMBAHASAN

1. Pengujian Sistem

Pengujian sistem dilakukan mulai dari pengujian alat permodul sampai pengujian alat secara

keseluruhan. Pengujian alat tersebut dilakukan secara bertahap dengan urutan sebagai

berikut :

Pengujian QR Code Scanner

Pengujian Sensor Ultrasonik

Pengujian Real-Time Clock (RTC)

Pengujian Push Button dan LED

Pengujian Buzzer

Pengujian NodeMCU dan Website

. Pengujian LCD

Pengujan Sistem Permodul

Adapun langkah yang harus dilalui dalam pemrograman mikrokontroler adalah sebagai

berikut :

1. Jalankan IDE Arduino dengan mengklik ganda ikon aplikasi arduino.exe, sehingga
aplikasi akan terbuka dan menampilkan halaman seperti gambar 7

@ sketch_dec28a | Arduine IDE 2.00 - o x

NoookrwdpE

Tooks Help

e Edit Sketch
sketch ¢

jec28a ino
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2. Lakukan pengetikan program, kemudian simpan pada folder yang diinginkan dengan
memilih menu File > Save, seperti gambar 8

B e | om0

Gambar 8 Tampilan Save As Program Arduino IDE

3. Setelah itu Compile program yang telah di buat tadi dengan memilih menu Sketch >
Verify/Compile.

4. Langkah selanjutnya yaitu mengupload file program yang telah di buat dan di kompilasi
tersebut kedalam board arduino yang digunakan sebagai kontroler dari alat.

5. Pertama — tama pasanglah kabel USB Printer Port ke arduino dan ke komputer/laptop

yang digunakan.

Kemudian pilih menu Sketch > Upload (Ctrl + U untuk cara lebih cepat).

7. Jika program sukses di upload ke dalam arduino, maka akan muncul tulisan “Done
uploading”.

o

Pengujian Sistem Keseluruhan

Setelah melakukan pengujian untuk masing-masing komponen seperti QR Code
Scanner, Sensor Ultrasonik, RTC, Push Button, LED,Buzzer, dan NodeMCU. Selanjutnya
akan dilakukan pengujian untuk sistem secara keseluruhan sebagai berikut:
1.  Sistem dalam keadaan mati ( belum dialiri oleh arus), dapat dilihat pada gambar 9

“.
N ) ® on

Scan QR-CODE

Gambar 9 Sistem Tidak Aktif
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2. Sistem aktif setelah tombol power ditekan LCD menampilkan SELAMAT DATANG
ABSENSI QRCODE dapat dilihat pada gambar 10

SELAMAT DRTANG
ABSENSIRQRCODE

Scan QR-CODE

3. Tekan Push Button untuk memilih mode “IN” (Masuk) atau “OUT” (Keluar)

Scan QR-CODE

Gambar 12 Tampilan Push Button OUT Aktif
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4. Siswa memindai QR Code dengan QR Code Scanner, pastikan jarak pemindaian kurang
dari 40 cm.

Gambar 13 Pemidaian QR Code
5. Jika pemindaian berhasil, nama siswa dan NIS akan ditampilkan di LCD.

o

Buzzer berbunyi sebagai tanda bahwa absensi berhasil tercatat.

RTC akan mencatat waktu absensi dan menampilkannya di website.

8. Kemudian data siswa yang telah melakukan absensi akan ditampilkan dihalaman
website,seperti gambar berikut.

~

Selsmat datang df SVIK TT ZAMIGA - Parit - Koto Halingka Kab. Pasaman Barat

Farooe|s2avmrs o [eroraas [0t | Cem

[ Rincian Absen
ULt

| xeeo0rua e AWM ROD " He o nay
nr 2 h o182 " AR ama 1 e

Gambar 15 Tampilan Data Absensi Siswa
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KESIMPULAN

Sistem absensi berbasis QR Code yang terintegrasi dengan teknologi Internet of Things
(IoT) yang diterapkan di laboratorium SMK TI ZAMIGA terbukti efektif dalam
meningkatkan efisiensi dan akurasi pencatatan kehadiran siswa secara otomatis dan real-time,
sekaligus mempermudah guru dalam pemantauan nilai praktikum harian melalui antarmuka
web yang terintegrasi, serta mendorong peningkatan kedisiplinan siswa berkat transparansi
data yang dapat diakses oleh pihak sekolah; oleh karena itu, untuk mendukung keberlanjutan
dan pengembangan sistem ke depannya, disarankan agar sistem diperluas ke seluruh area
sekolah menggunakan server cluster untuk mengoptimalkan distribusi beban, dilengkapi
dengan fitur enkripsi data dan koneksi jaringan yang lebih stabil melalui modul Ethernet
untuk meningkatkan keamanan, diintegrasikan dengan teknologi biometrik seperti fingerprint
atau face recognition untuk validasi kehadiran yang lebih akurat, serta ditambahkan fitur
notifikasi otomatis kepada orang tua dan backup data berbasis cloud guna menjaga
keamanan, keandalan, dan aksesibilitas data meskipun terjadi gangguan sistem.
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